PROBLEM:
ShopFactory does not properly install on Microsoft Windows Vista.
ShopFactory 7 is compatible with Microsoft Vista. However you may run into the following problem due to an internal Microsoft Vista conflict.
SYMPTOMS:
While installing ShopFactory on Windows Vista, during the installation the following error occurs with the message:
"Internal Error: Failed to expand shell folder constant "userdocs" following " Setup was not completed. Please correct the problem and run Setup again"
CAUSE:
This problem is caused by an internal Vista conflict which also affects other software packages.
RESOLUTION:
Set the folder "my documents" to its default values.
Right click on my documents folder in explorer or the desktop
> select properties from the menu that appears
> Select the option for returning the position to its default value.
C:\Documents and settings
> All Users Documents
> under properties you will see attributes and the settings for "read only"
Setting back the default value for "My documents" is just a workaround, which usually fixes the default read/write rights for the "My Documents" folder.
If this does not resolve your issue you will need to contact Microsoft support.