14-0020-EN-"Internal Error: Failed to expand shell folder constant "userdocs" following " Setup was not completed. Please correct the problem and run Setup again"

Article Details
URL: https://support.shopfactory.com/kayako/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=461
Article ID: 461
Created On: 26 Apr 2007 12:00 AM

Answer

Problem: ShopFactory does not Install at all on Windows Vista

SYMPTOMS:
While installing ShopFactory on Windows Vista, during the installation the following error occurs with the message:

"Internal Error: Failed to expand shell folder constant "userdocs"following " Setup was not completed. Please correct the problem and runSetup again"

CAUSE:
This problem is caused from a Vista conflict.

RESOLUTION:
Set the folder "my documents" to its default values.

1. Right Click on Start
2. Select Explore from the Menu
3. Right Click on the "My Documents" Folder
4. Click on Properties and it will open up the Document Properties Dialog box
5. Click on the General Tab, this should be the default
6. You will see a small box "Read only" at the bottom next to Attributes - click on this box to untick /de-select this option
7. Click on the Apply button
8. Click on Ok to close the Document Properties dialog and save the changes.


Setting back the default value for "My documents" is just a workaround,which usually fixes the default read/write rights for the "MyDocuments" folder.

Try installing ShopFactory again.

If this does not resolve your issue you will need to contact Microsoft support.